PAT 1058. A+B in Hogwarts

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28

#include<iostream>
#include<vector>
using namespace std;
int main(){
	vector<int> p1(3),p2(3),res(3);
	scanf("%d.%d.%d",&p1[0],&p1[1],&p1[2]);
	scanf("%d.%d.%d",&p2[0],&p2[1],&p2[2]);
	int add;
	res[2]=(p1[2]+p2[2])%29;
	res[1]=(p1[1]+p2[1]+(p1[2]+p2[2])/29)%17;
	res[0]=(p1[0]+p2[0]+(p1[1]+p2[1]+(p1[2]+p2[2])/29)/17);
	printf("%d.%d.%d",res[0],res[1],res[2]);
	return 0;
} 
posted @ 2018-01-27 09:07  A-Little-Nut  阅读(117)  评论(0编辑  收藏  举报