PAT 1054. The Dominant Color

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:
24

分析
很OK,开一个数组超限了,就用map了。

#include<iostream>
#include<map>
using namespace std;
int main(){
	map<int,int> checked;
	int m,n,t;
	cin>>m>>n;
	for(int i=0;i<m;i++)
	   for(int j=0;j<n;j++){
	   	   cin>>t;
	   	   checked[t]++;
	   	   if(checked[t]>m*n/2)
	   	      cout<<t; 
	   }
    return 0;
} 
posted @ 2018-01-23 15:39  A-Little-Nut  阅读(152)  评论(0编辑  收藏  举报