Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output

For each case, output the minimum inversion number on a single line.

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16


 

 

题意:就是给出一串数,当依次在将第一个数变为最后一个数的过程中,要你求它的最小逆序数。

题解:采用线段树维护数据。边输入,边记录每个数字之前比他小的数据。

#include <iostream>  
#include <cstdio>  
using namespace std;


int sum[24000]; 

int min(int a, int b)
{
    if (a > b)return b;
    return a;
}

void pushUp(int rt)
{
    sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}

void build(int l, int r, int rt)
{
    sum[rt] = 0; 
    if (l == r) return;
    int m = (l + r) >> 1;
    build(l, m, rt << 1);
    build(m + 1, r, rt << 1 | 1);
}

void update(int p, int l, int r, int rt)
{
    if (l == r) {
        sum[rt]++; return;
    }
    int m = (l + r) >> 1;
    if (p <= m) update(p, l, m, rt << 1);
    else update(p, m + 1, r, rt << 1 | 1);
    pushUp(rt);
}

int query(int L, int R, int l, int r, int rt)
{
    if (l >= L && r <= R) return sum[rt];

    int m = (l + r) >> 1, ans = 0;
    if (m >= L) ans += query(L, R, l, m, rt << 1);
    if (m < R) ans += query(L, R, m + 1, r, rt << 1 | 1);
    return ans;
}

int main()
{
    int sum,n, s[6000];

    while (scanf("%d", &n) != EOF)
    {
        build(0, n - 1, 1);
        sum = 0;
        for (int i = 0; i < n; i++)
        {
            scanf("%d", &s[i]);
            sum += query(s[i], n - 1, 0, n - 1, 1);
            update(s[i], 0, n - 1, 1);
        }
        int ans = sum;
        for (int i = 0; i < n; i++)
        {

            sum = sum + n - 2 * s[i] - 1;
            ans = min(ans, sum);
        }
        printf("%d\n", ans);
    }
}

 

posted on 2016-08-30 17:04  波函数崩塌者  阅读(92)  评论(0编辑  收藏  举报