Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0


 

 

#include<stdio.h>  
#include<string.h>  
#include<queue>
using namespace std;

int su[10000];
int s1[10000],c1,c2,c,d,judge;

int pow(int a, int b)
{
    int k = 1;
    for (int i = 1;i <= b;i++)k *= a;
    return k;
}

int pd(int a)
{
    if (su[a] == 0 && s1[a] == 0 && a >= 1000&&a!=c1)return 1;
    return 0;
}

int main()
{
    queue<int>a, b;
    memset(su, 0, sizeof(su));
    for (int i = 2;i < 10000;i++)
        for (int j = 2;i*j < 10000;j++)
            if (su[i] == 0)su[i*j] = 1;
    //for (int i = 1;i < 10000;i++)
        //if (su[i]==0)printf("%d \n", i);


    int T;
    while (scanf("%d", &T) != EOF)
    {
        while (T--) 
        {
            judge = 0;
            memset(s1, 0, sizeof(s1));
            while (a.size()) { a.pop();b.pop(); }
            scanf("%d%d", &c1, &c2);
            a.push(c1);
            b.push(0);
            while (a.size())
            {
                c = a.front();d = b.front();
                a.pop();
                b.pop();
                s1[c] = d;
                if (c == c2) break; 
                for (int i = 1;i <= 4;i++)for (int j = 0;j <= 9;j++)
                {
                    judge = (c / pow(10, i))*pow(10, i) + c%pow(10, i-1) + j*pow(10, i - 1);
                    if(su[judge]==0)
                    if (pd(judge)) { a.push(judge);b.push(d + 1); }
                }
            }
            printf("%d\n", s1[c2]);

        }
    }

}

 

posted on 2016-08-30 16:28  波函数崩塌者  阅读(101)  评论(0编辑  收藏  举报