Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 
 
 
 
 
题意:a走到b,3种移动方式。
题解:搜索。
AC代码:
#include<string.h>
#include<stdio.h>
#include<queue>
#include<stack>
using namespace std;



int road[200000];

int main()
{
    queue<int>q, step;
    int n,k,x0,st0;
    while (scanf("%d%d", &n, &k) != EOF)
    {
        memset(road, -1, sizeof(road));
        while (q.size()) { q.pop(); step.pop(); }
        q.push(n);
        step.push(0);
        //road[n] = 0;
        while (q.size())
        {
            x0 = q.front();
            q.pop();
            st0 = step.front();
            step.pop();
            road[x0] = st0;
            if (x0 == k) { printf("%d\n", road[k]);break; }
            if (x0 - 1 >= 0 && road[x0 - 1] < 0) { q.push(x0 - 1);step.push(st0 + 1); }
            if (x0 +1 <= 100000 && road[x0 + 1] < 0) { q.push(x0 + 1);step.push(st0 + 1); }
            if (x0*2<=100000&& road[x0 *2] < 0) { q.push(x0 *2);step.push(st0 + 1); }
        }
    }
}

 

 
 
 
posted on 2016-08-30 16:20  波函数崩塌者  阅读(125)  评论(0编辑  收藏  举报