Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
 





题意:一个地图,有障碍,问从指定起始位置能到多少不同位置。
题解:随意地图题,dfs或者bfs。
AC代码:

#include<string.h>
#include<stdio.h>
#include<queue>
using namespace std;

int map[30][30];


int main()
{
    char c;
    queue<int>x, y;
    int w, h,ans;
    int x0, y0;
    while (scanf("%d%d", &w, &h) != EOF&&w)
    {
        while (x.empty() != 1) { x.pop();y.pop(); }
        memset(map, 0, sizeof(map));
        for (int i = 1;i <= h; i++)
        {            
            getchar();
            for (int j = 1;j <= w;j++)
            {
                c = getchar();
                if (c == '#')map[i][j] = 1;
                if (c == '@') { x.push(i);y.push(j); }
            }
        }


        while (x.size())
        {
            x0 = x.front();
            y0 = y.front();
            x.pop();
            y.pop();
            map[x0][y0] = -1;
            if (x0 - 1 >= 1 && map[x0 - 1][y0] == 0) { x.push(x0 - 1);y.push(y0); }
            if (y0 - 1 >= 1 && map[x0][y0 - 1] == 0) { x.push(x0);y.push(y0 - 1); }
            if (x0 + 1 <= h && map[x0 + 1][y0] == 0) { x.push(x0 + 1);y.push(y0); }
            if (y0 + 1 <= w && map[x0][y0 + 1] == 0) { x.push(x0);y.push(y0 + 1); }
        }
        ans = 0;
        for (int i = 1;i <= h;i++)
            for (int j = 1;j <= w;j++)
                if (map[i][j] == -1)ans++;
        printf("%d\n", ans);


        
    }

}

 


posted on 2016-08-30 16:11  波函数崩塌者  阅读(105)  评论(0编辑  收藏  举报