Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. You are asked to implement this. The commands are:

  1. BACK: If the backward stack is empty, the command is ignored. Otherwise, push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page.
  2. FORWARD: If the forward stack is empty, the command is ignored. Otherwise, push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page.
  3. VISIT <url>: Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.
  4. QUIT: Quit the browser.

The browser initially loads the web page at the URL 'http://www.lightoj.com/'

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains some commands. The keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 50 characters. The end of case is indicated by the QUIT command and it shouldn't be processed. Each case contains at most 100 lines.

Output

For each case, print the case number first. For each command, print the URL of the current page (in a line) after the command is executed if the command is not ignored. Otherwise, print 'Ignored'.

Sample Input

1

VISIT http://uva.onlinejudge.org/

VISIT http://topcoder.com/

BACK

BACK

BACK

FORWARD

VISIT http://acm.sgu.ru/

BACK

BACK

FORWARD

FORWARD

FORWARD

QUIT

Sample Output

Case 1:

http://uva.onlinejudge.org/

http://topcoder.com/

http://uva.onlinejudge.org/

http://www.lightoj.com/

Ignored

http://uva.onlinejudge.org/

http://acm.sgu.ru/

http://uva.onlinejudge.org/

http://www.lightoj.com/

http://uva.onlinejudge.org/

http://acm.sgu.ru/

Ignored

就是一个运用栈的练习水题。

AC代码:

#include<stdio.h>
#include<stdlib.h>
#include<stack>
#include<string.h>
#include<string>
#include<iostream>
using namespace std;
string s[10000];
char s1[100];
string dang;
string homepage = "http://www.lightoj.com/";
int main()
{
    stack<string>hou, qian;
    int T, k, d;
    while (scanf("%d", &T) != EOF)
    {            getchar();

        for (int l = 1;l <= T;l++)
        {
            printf("Case %d:\n",l);
            k = 0;
            dang = homepage;
            while (hou.size() != 0)hou.pop();
            while (qian.size() != 0)qian.pop();
            while (1)
            {
                gets(s1);
                if (s1[0] == 'Q') {break; }
                if (s1[0] == 'V')
                {
                    puts(&s1[6]);
                    k++;
                    s[k] = dang;
                    qian.push(s[k]);
                    dang = &s1[6];
                    while (hou.size() != 0)hou.pop();
                }
                if (s1[0] == 'B')
                {
                    if (qian.size() == 0)printf("Ignored\n");
                    else
                    {
                        cout << qian.top() << endl;
                        k++;
                        s[k] = dang;
                        hou.push(s[k]);
                        dang = qian.top();
                        qian.pop();
                    }
                }
                if (s1[0] == 'F')
                {
                    if (hou.size() == 0)printf("Ignored\n");
                    else
                    {
                        cout << hou.top() << endl;
                        k++;
                        s[k] = dang;
                        qian.push(s[k]);
                        dang = hou.top();
                        hou.pop();
                    }
                }
            }



        }

    }

}

 

posted on 2016-08-30 15:47  波函数崩塌者  阅读(226)  评论(0编辑  收藏  举报