A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found



先声明一点,如果用int存id,输出一定要是7位,不够前补零,本来可以很快做出来,结果搞了半天还以为是char[]作为string传到map有问题(始终用的同一个字符数组),其次题目c++编译器里gets不支持了,
这道题字符读入比较麻烦,题目中要求把每个信息孤立进行记录不交叉,查询的时候也是根据编号查特定项信息,所以用一个map数组,记录不同项中的字符串映射,映射到特定的set,每个字符串对应一个set,记录
其包含的编号,查询也是根据映射去找,按顺序输出即可。

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
#include <set>
#include <map>
using namespace std;
#define inf 0x3f3f3f3f
int n,m,id,c[5];
set<int> mp[5][10001];
map<string,int> po[5];
string s;
char str[1000];
int main() {
    cin>>n;
    for(int i = 0;i < n;i ++) {
        cin>>id;
        getchar();
        getline(cin,s);///title
        if(!po[0][s])po[0][s] = ++ c[0];
        mp[0][po[0][s]].insert(id);
        getline(cin,s);///author
        if(!po[1][s])po[1][s] = ++ c[1];
        mp[1][po[1][s]].insert(id);
        int ss = 0;///key words
        while((str[ss ++] = getchar())) {
            if(str[ss - 1] == ' ') {
                str[ss - 1] = 0;
                ss = 0;
                s = str;
                if(!po[2][s])po[2][s] = ++ c[2];
                mp[2][po[2][s]].insert(id);
            }
            else if(str[ss - 1] == '\n') {
                str[ss - 1] = 0;
                ss = 0;
                s = str;
                if(!po[2][s])po[2][s] = ++ c[2];
                mp[2][po[2][s]].insert(id);
                break;
            }
        }
        getline(cin,s);///publisher
        if(!po[3][s])po[3][s] = ++ c[3];
        mp[3][po[3][s]].insert(id);
        getline(cin,s);///year
        if(!po[4][s])po[4][s] = ++ c[4];
        mp[4][po[4][s]].insert(id);
    }
    cin>>m;
    getchar();
    for(int i = 0;i < m;i ++) {
        getline(cin,s);
        cout<<s<<endl;
        int num = s[0] - '1';
        int d = po[num][s.substr(3,s.size())];
        if(!d) {
            printf("Not Found\n");
        }
        else {
            for(set<int>::iterator it = mp[num][d].begin();it != mp[num][d].end();it ++) {
                printf("%07d\n",*it);
            }
        }
    }
}