Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 
 
 
bfs记录每一步的步数,对位置标记,去过的位置不必再去。
 
代码:
 
#include <iostream>
#include <queue>
#include <cstdlib>
#include <cstdio>
#include <cstring>
using namespace std;

struct que {
    int x,t;///x记录位置 t记录步数
}head,temp;
int vis[200200];
int main() {
    ios::sync_with_stdio(false);
    cin.tie(0);
    int n,k;
    while(~scanf("%d%d",&n,&k)) {
        memset(vis,0,sizeof(vis));//归零
        queue<que> q;
        temp.x = n;
        vis[n] = 1;
        temp.t = 0;
        q.push(temp);
        while(!q.empty() && q.front().x != k) {
            head = q.front();
            q.pop();
            if(head.x < k) {
                if(!vis[head.x * 2]) {
                    temp.x = head.x * 2;
                    vis[temp.x] = 1;
                    temp.t = head.t + 1;
                    q.push(temp);
                }
                if(!vis[head.x + 1]) {
                    temp.x = head.x + 1;
                    vis[temp.x] = 1;
                    temp.t = head.t + 1;
                    q.push(temp);
                }
            }
            if(head.x >= 1 && !vis[head.x - 1]) {///约束条件
                temp.x = head.x - 1;
                vis[temp.x] = 1;
                temp.t = head.t + 1;
                q.push(temp);
            }
        }
        printf("%d\n",q.front().t);
    }
    return 0;
}