【搜索BFS】poj3278--Catch That Cow(bfs)

                                    Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
     

 

Description

Farmer John has been informed of the location of a fugitive(逃亡的;难以捉摸的;短暂的) cow and wants to catch her immediately. He starts at a pointN(0 ≤N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 orX+ 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit(追赶;工作), does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N andK

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意:在一维坐标系中,给定John的位置,还有cow的位置,john有2种行动方式,(一)向前走一步(-1),想后走一步(+1);(二)跳到当前位置的2倍位置。

 问:最少需要多少时间(分钟)可以抓到cow。

【用vis数组优化】:如果不加“代码中阴影”,会RE

【bfs搜索即可】:

#include<stdio.h>
#include<string.h>
int dx[3]={-1, 1, 2};
int vis[3000000];
int n, k;
struct node{
    int x, ans;
}q[3000000], t, f;

void bfs()
{
    memset(vis, 0, sizeof(vis));
    memset(q, 0, sizeof(q));
    int s=0, e=0;
    vis[n] = 1;
    q[s++].x = n;
    t.ans = 0;
    while(s>e)
    {
        t = q[e++];
        for(int i=0; i<3; i++)
        {
            if(i!=2)
                f.x = t.x+dx[i];
            else
                f.x = t.x*dx[i];
            f.ans = t.ans+1;
            if(f.x==k)
            {
                printf("%d\n", f.ans);
                return;
            }
            else{
                if(!vis[f.x] && (f.x>0 && f.x<100000) )
                {
                       vis[f.x] = 1;
                    q[s++] = f;
                }
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d", &n, &k))
    {
        if(n>=k)
        {
            printf("%d\n", n-k);
            continue;
        }
        else
        {
            bfs();
        }
    }
    return 0;
}

 

posted @ 2014-11-24 16:17  6bing  阅读(150)  评论(0编辑  收藏  举报