POJ 1006 ( 中国剩余定理 )


                                                                                                              Biorhythms
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 112904   Accepted: 35320

Description

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:Case 1: the next triple peak occurs in 1234 days.Use the plural form ``days'' even if the answer is 1.

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.


代码如下:

#include<stdio.h>
#include<math.h>

#define LL long long
LL MM[10], NN[10], m[10]={23, 28, 33}, x, y;

int extend_gcd(LL a, LL b, LL &x, LL &y)
{
    if(b==0) { x=1; y=0; return a;}
    LL d = extend_gcd(b, a%b, x, y);
    LL t = x;
       x = y;
       y = t-a/b*y;
    return d;
}

int main()
{
    int p, e, i ,d, j, k=0;
    LL M, X, dd;
    while(~scanf("%d%d%d%d", &p, &e, &i, &d))
    {

        if(p==-1 && e==-1 && i==-1 && d==-1)
           break;
        M = m[0]*m[1]*m[2];
        
        for(j=0; j<3; j++)
            MM[j] = M/m[j];
    
        for(j=0; j<3; j++)
        {
            dd =  extend_gcd(MM[j], m[j], x, y);
            x = x*(1/dd);
            x = (x%m[j]+m[j])%m[j];
            NN[j] = x;
        }

       X = (MM[0]*NN[0]*p + MM[1]*NN[1]*e + MM[2]*NN[2]*i)% M;

         if(X==21252 && d==21252)
            printf("Case %d: the next triple peak occurs in 21252 days.\n", ++k);
         else if(X==0 && d!=21252)
            printf("Case %d: the next triple peak occurs in %d days.\n",  ++k, 21252-d);
        else  printf("Case %d: the next triple peak occurs in %lld days.\n",  ++k, (X+21252-d)%21252);
    }
    return 0;
}


此题注意判断当X==0  的情况,   else if(X==0 && d!=21252)  直接输出 21252-d 即可。

                    而当X==21252 && d==21252时,直接输出 21252 即可。

                    其他情况直接输出 (X+21252-d)%21252  这里是为保证为正数。


中国剩余定理:

————————————————————————————————————————————————————————————————————————————

形式描述

用现代数学的语言来说明的话,中国剩余定理给出了以下的一元线性同余方程组:

(S) : \quad \left\{ \begin{matrix} x \equiv a_1 \pmod {m_1} \\ x \equiv a_2 \pmod {m_2} \\ \vdots \qquad\qquad\qquad \\ x \equiv a_n \pmod {m_n} \end{matrix} \right.

有解的判定条件,并用构造法给出了在有解情况下解的具体形式。

中国剩余定理说明:假设整数m1, m2, ... , mn两两互质,则对任意的整数:a1, a2, ... , an,方程组(S)有解,并且通解可以用如下方式构造得到:

  1. M = m_1 \times m_2 \times \cdots \times m_n = \prod_{i=1}^n m_i是整数m1, m2, ... , mn的乘积,并设M_i = M/m_i, \; \; \forall i \in \{1, 2, \cdots , n\}是除了mi以外的n - 1个整数的乘积。
  2. t_i = M_i^{-1}M_im_i的数论倒数:t_i M_i \equiv 1 \pmod {m_i},  \; \; \forall i \in \{1, 2, \cdots , n\}.
  3. 方程组(S)的通解形式为:x = a_1 t_1 M_1 + a_2 t_2 M_2 + \cdots + a_n t_n M_n + k M= k M + \sum_{i=1}^n a_i t_i M_i, \quad k \in \mathbb{Z}. 在模M的意义下,方程组(S)只有一个解:x = \sum_{i=1}^n a_i t_i M_i.

————————————————————————————————————————————————————————————————————————————

此题中的变量对应公式中:  a1 = p,     m1 = 23;      Mi ~~MM[ j ];  ti ~~NN[ j ];    

                                                  a2 = e,     m2 = 28;

                                                  a3 =  i,     m3 = 33;

      此题运用中国剩余定理,然后在求 ti 的时候运用拓展欧几里得即可。

posted @ 2014-08-06 21:25  6bing  阅读(149)  评论(0编辑  收藏  举报