POJ--2386 Lake Counting(DFS)

记录
23:18 2022-12-25

http://poj.org/problem?id=2386

reference:《挑战程序设计竞赛(第2版)》2.1.4 p33

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

  • Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

简单的一个dfs,需要注意的是把思维打开,dfs是一种思想,不单单是图的专属。

也可以看成是具有不相交集合的图(意思是有孤立的没和其它图有连线),这样dfs图需要照顾到每个集合(也就是将有边的图走一遍)
上面这一句说了这么多,简单概括就是求有几个孤立图的时候的做法(我废话真多)

图中的dfs是找存在的边,这里需要看存在的边是四周八个方向,依次dfs八个方向,将存在W的地方变成.(.表示土地,表示已经遍历过了),这样最后遍历的次数就是孤立图的个数。

#include<cstdio>
int N, M;
#define MAX_N 10000
#define MAX_M 10000
char field[MAX_N][MAX_M + 1];

//现在的位置是x, y
void dfs(int x, int y) {
    field[x][y] = '.'; // 将现在的位置替换为.

    //遍历8个方向
    for (int dx = -1; dx <= 1; dx++) {
        for (int dy = -1; dy <= 1; dy++) {
            //移动的结果是nx,ny
            int nx = x + dx, ny = y + dy;
            //判断nx,ny是否再园子里且是否有积水
            if (0 <= nx && nx < N && 0 <= ny && ny < M && field[nx][ny] == 'W' ) dfs(nx, ny);
        }
    }
    return ;
}

void solve() {
    int res = 0;
    for(int i = 0; i < N; i++) {
        for(int j = 0; j < M; j++){
            if(field[i][j] == 'W') {
                //从有W的地方开始dfs
                dfs(i, j);
                res++;
            }
        }
    }
    printf("%d\n", res);
}

int main() {
    while (~scanf("%d %d\n", &N, &M)) {
        for(int i = 0; i < N; i++) {
            for(int j = 0; j < M; j++){
                scanf("%c", &field[i][j]);
            }
            getchar();
        }
        solve();
    }
    // while(~scanf("%d %d",&N,&M)){
    //     for(int i=0;i<=N-1;i++){   
    //         scanf("%s",field[i]);
    //     }
    //     solve();
    // }
}
posted @ 2022-12-26 00:25  57one  阅读(15)  评论(0编辑  收藏  举报