Hdu 1576 A/B

A/B

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 592    Accepted Submission(s): 475


Problem Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
 

 

Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
 

 

Output
对应每组数据输出(A/B)%9973。
 

 

Sample Input
2 1000 53 87 123456789
 

 

Sample Output
7922 6060
 

 

Author
xhd
 

 

Source
 

 

Recommend
linle

//扩展欧几里得算法、水题收录

#include <iostream>
#include <stdio.h>
using namespace std;
int x,y;
//int d;
void kzgcd(int a,int b)
{
  if(!b)
      x=1,y=0;
  else
  {
     kzgcd(b,a%b);
     int t=y;
     y=x-(a/b)*y;
     x=t;
  }
}
int main()
{
    int n,b;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&b);
        kzgcd(b,9973);
        while(x<0) x+=9973;
        printf("%d\n",x*n%9973);
    }
}

posted on 2012-07-21 15:10  江财小子  阅读(204)  评论(0编辑  收藏  举报