HDU 2602 Bone Collector(背包)

 

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

 

 

Input

 

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

 

 

Output

 

One integer per line representing the maximum of the total value (this number will be less than 231).

 

 

 

Sample Input

 

1 5 10 1 2 3 4 5 5 4 3 2 1

 

 

 

Sample Output

 

14
//最基本的0-1背包,模板了,

 #include <cmath>

#include <queue>
#include <cstdio>
#include <cstdlib>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
int
main()
{

  int
t,V,n,v[1003],c[1003],dp[1003];
  int
i,j;
  scanf("%d",&t);
  while
(t--)
  {
  memset(dp,0,sizeof(dp));
      scanf("%d%d",&n,&V);
      for
(i=0;i<n;i++)
        scanf("%d",&c[i]);
      for
(i=0;i<n;i++)
        scanf("%d",&v[i]);
      for
(i=0;i<n;i++)
         for
(j=V;j>=v[i];j--)
           dp[j]=dp[j]>dp[j-v[i]]+c[i]?dp[j]:dp[j-v[i]]+c[i];
      printf("%d\n",dp[V]);

  }

    return
0;
}


posted on 2012-04-06 16:05  江财小子  阅读(135)  评论(0编辑  收藏  举报