hdu 1009 FatMouse' Trade

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42882    Accepted Submission(s): 14310


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

 

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
 

 

Sample Output
13.333
31.500
 

 

 

 

 

#include<iostream>
#include<algorithm>
using namespace std;

struct room
{
    double n;
    double h;
};


int cmp(room a, room b)
{
    return a.h/a.n > b.h/b.n;

}

int main()
{
    int v;
    int n;
    room r[1100];
    while(cin>>v>>n)
    {
        if(v == -1)break;
        int i;
        double total = 0;
        for(i = 0; i < n; ++i)
            cin>>r[i].h>>r[i].n;
        sort(r,r+n,cmp);

    /*    for(i = 0; i < n; ++i)
            cout<<r[i].h<<' '<<r[i].n<<endl;*/
        for(i = 0 ; i < n ; ++i)
        {
            if(v == 0)break;
            if(v >= r[i].n)
            {
                v -= r[i].n;
                total += r[i].h;
            }
            else {
                total += r[i].h/r[i].n*v;
            //    v = 0;
                break;
            }
        }
        printf("%.3lf\n",total);
    }
    return 0;
}
View Code

#include<iostream>
#include<algorithm>
using namespace std;

struct room
{
    double n;
    double h;
};


int cmp(room a, room b)
{
    return a.h/a.n > b.h/b.n;

}

int main()
{
    int v;
    int n;
    room r[1100];
    while(cin>>v>>n)
    {
        if(v == -1)break;
        int i;
        double total = 0;
        for(i = 0; i < n; ++i)
            cin>>r[i].h>>r[i].n;
        sort(r,r+n,cmp);

    /*    for(i = 0; i < n; ++i)
            cout<<r[i].h<<' '<<r[i].n<<endl;*/
        for(i = 0 ; i < n ; ++i)
        {
            if(v == 0)break;
            if(v >= r[i].n)
            {
                v -= r[i].n;
                total += r[i].h;
            }
            else {
                total += r[i].h/r[i].n*v;
            //    v = 0;
                break;
            }
        }
        printf("%.3lf\n",total);
    }
    return 0;
}

 

posted @ 2014-08-01 17:25  2014acm  阅读(108)  评论(0编辑  收藏  举报