What Are You Talking About

What Are You Talking About

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 102400/204800K (Java/Other)
Total Submission(s) : 43   Accepted Submission(s) : 14

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

Output

In this problem, you have to output the translation of the history book.

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END

Sample Output

hello, i'm from mars.
i like earth!

Hint

Huge input, scanf is recommended.

Author

Ignatius.L
这题使用了字典树
建立了一个结构体
struct map
{
 char key[10];
 map *next[26];
 
}
要注意初始化;
#include<iostream>
using namespace std;
struct map
{
    char key[10];//记录翻译的结果
    map *next[26];//26个字母

};
void insert(map *first,char key[],char value[])
{
    int i;
    int l;
    l=strlen(value);
    for(i=0;i<l;i++)
    {
        if(first->next[value[i]-'a']!=NULL)//不为空找下一个字母
        {
            first=first->next[value[i]-'a'];
        
        }
        else
        {
            map *mid;
            mid=(map *)malloc(sizeof(map));//为空 创建以个新的节点
            int j;
            for(j=0;j<26;j++)
            {
                mid->next[j]=NULL;//指针初始化为空
            
            }
            char space[10]="\0";
            strcpy(mid->key,space);//key的值初始化为空
            first->next[value[i]-'a']=mid;
            first=first->next[value[i]-'a'];

        
        }
    
    }
    strcpy(first->key,key);//拷贝key值


}
void search(map *top,char now[])
{
    int l;
    int i;
    l=strlen(now);
    for(i=0;i<l;i++)
    {
        if(top->next[now[i]-'a']==NULL)//如果为空就可以判断没有这个单词的翻译
        {
            
            printf("%s",now);
            return ;
        
        }
        else
        {
            top=top->next[now[i]-'a'];//不为空找下一个字母
        
        }

    
    }
    if(strlen(top->key))//判断有没有key值
    {
    printf("%s",top->key);
    }
    else 
    {
        printf("%s",now);//没有key值输出原来的值
    }
    return ;

}
int main()
{
    map *top;
    top=(map *)malloc(sizeof(map));
    int i;
    char juzhi[3010];
    char key[10];
    char value[10];
    char space[10]="\0";
    char start[6]={'S','T','A','R','T','\0'};
    char end[4]={'E','N','D','\0'};
    for(i=0;i<26;i++)
    {
        top->next[i]=NULL;
    
    }
    strcpy(top->key,space);//初始化
    scanf("%s",&key);
    if(!strcmp(key,start))
    {
        while(scanf("%s",&key))
        {
            if(!strcmp(key,end))
                break;
            scanf("%s",&value);
            insert(top,key,value);
        }
    
    
    
    }//输入字典



    scanf("%s",&juzhi);
    if(!strcmp(juzhi,start))
    {
        getchar();//吃掉回车
        while(gets(juzhi))//得到这一行的句子
        {
            if(!strcmp(juzhi,end))
                break;

            int j;
            int l;
            l=strlen(juzhi);
            for(j=0;j<l;)
            {
                if(juzhi[j]>='a'&&juzhi[j]<='z')
                {
                    int m;
                    m=j;
                    char danchi[11]="";
                    int chang=0;
                    while(juzhi[m]>='a'&&juzhi[m]<='z')
                    {
                        danchi[chang++]=juzhi[m++];
                    
                    }//找单词 
                    search(top,danchi);//把找到的单词与字典对照
                    j=m;
                
                }
                else
                {
                    printf("%c",juzhi[j++]);//不是字母直接输出
                }

            
            }
            
            printf("\n");

            
        
        
        }
        
    }


    





    return 0;
}
/*
START
from fiwo
hello difh
trap dif
mars riwosf
earth fnnvk
like fiiwj
END
START
i fiiwj fnnvk! dif fnn

//测试数组
*/

 

 
posted @ 2013-08-25 11:25  一只蚊子  阅读(310)  评论(0编辑  收藏  举报