The kth great number

The kth great number

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65768/65768K (Java/Other)
Total Submission(s) : 28   Accepted Submission(s) : 6

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.

Output

The output consists of one integer representing the largest number of islands that all lie on one line.

Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q

Sample Output

1
2
3

Hint

Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).

Source

The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest
这里要运用优先队列 但是要人为的控制 队列 的长度
还要重载<号 是的优先队列 升序
因为控制 队列的长度 所以 对头就是答案
#include<iostream>
#include<queue>
using namespace std;
struct number
{
    int num;

};
bool operator <(const number  &a,const number  &b)
{
    return a.num>b.num;

}//重载
int main()
{
    int n,k;//n行的输入 第k的数
    while(scanf("%d %d",&n,&k)!=EOF)
    {
        priority_queue<number> abb;//记录数据 队列按升序排
        int  x;
        number shu;//数值
        char word;//命令 I / Q
        for(x=0;x<n;x++)
        {
            cin>>word;
            if(word=='Q')
            {
                printf("%d\n",abb.top().num);
            
            }
            if(word=='I')//输入
            {
                scanf("%d",&shu.num);
                if(abb.size()<k)
                {
                    abb.push(shu);
                    
                    
                
                }
                else
                {
                    if(shu.num>abb.top().num)//比第k大的数大 
                    {
                        abb.pop();
                        abb.push(shu);
                    
                    }
                
                }
            
            }

        
        
        }



    
    
    
    }





return 0;
}

 

posted @ 2013-08-15 20:38  一只蚊子  阅读(205)  评论(0编辑  收藏  举报