poj 2777 Count Color

Count Color
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 31731   Accepted: 9508

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C.
2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1
//过了然后去百度,网上说用位操作==
//没想到,也不会,
// 这里我用的是vi[]标记是否用过这种颜色用过没。
#include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>
using namespace std ;

#define maxn 100002
int set[maxn*4] ;
int  ql ,qr , v , ans ;
bool vi[31] ;

void push( int o )
{
    int lc = (o<<1) , rc = (o<<1|1) ;
    if( set[o] >= 1 )
    {  // 把颜色往下传
        set[lc] = set[rc] = set[o] ;
        set[o] = -1 ;
    }
}
void update( int L , int R , int o )
{
    int mid = (L+R)>>1 ;
    if( L >= ql && qr >= R )
    {
        set[o] = v ;
    }
    else
    {
        push(o) ;
        if( mid >= ql )update(L,mid,o<<1) ;
        if( mid < qr )update(mid+1,R,o<<1|1) ;
    }
}
void  find( int L ,int R , int o )
{
    int mid =(L+R)>>1 ;
    if( set[o] >= 1 )
    {
        if(!vi[set[o]]){
            vi[set[o]] = 1 ;
            ans++ ;
        }
        return ;
    }
        if( L == R ) return ;
        if( ql <= mid ){ find(L,mid,o<<1)  ;}
        if( qr > mid ){ find(mid+1,R,o<<1|1) ;}
}
int main()
{
    int i , j , n , m ;
    char a ;
    while( scanf("%d%d%d" , &n , &j , &m ) != EOF )
    {
        ql = 1 ;
        qr = n ;v = 1 ;
        update(1,n,1) ;
        while( m-- )
        {
            scanf(" %c",&a ) ;
            if( a == 'C')
            {
                scanf("%d%d%d",&ql,&qr,&v ) ;
                update(1,n,1) ;
            }
            else 
            {
                scanf("%d%d" , &ql , &qr ) ;
                ans = 0 ;
                memset(vi,0,sizeof(vi)) ;
                find(1,n,1) ;
                printf("%d\n",ans) ;
            }
        }
    }
}

 

posted @ 2013-09-04 18:54  _log__  阅读(154)  评论(0编辑  收藏  举报