L1-023. 输出GPLT

题目连接: https://www.patest.cn/contests/gplt/L1-023

L1-023. 输出GPLT

时间限制
150 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“GPLTGPLT....”这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:
pcTclnGloRgLrtLhgljkLhGFauPewSKgt
输出样例:
GPLTGPLTGLTGLGLL



#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
void statistics(int &G, int &P, int &L, int &T, char a[])
{
    int len = strlen(a);
    for(int i=0; i<len; i++)
    {
        if(a[i]=='g'||a[i]=='G')
            G++;
        if(a[i]=='p'||a[i]=='P')
            P++;
        if(a[i]=='l'||a[i]=='L')
            L++;
        if(a[i]=='t'||a[i]=='T')
            T++;
    }
    return;
}
int main()
{
    char ch[10001];
    gets(ch);
    int G=0,P=0,L=0,T=0;
    statistics(G, P, L, T, ch);
    int  a[4];
    a[0]=G;
    a[1]=P;
    a[2]=L;
    a[3]=T;
    sort(a, a+4);
    int most = a[3];  //拿到GPLT中数目最多的元素,
    for(int i=0; i<most; i++)  //循环输出GPLT
    {
        if(G>0)
        {
            cout << "G";
            G--;
        }
        if(P>0)
        {
            cout << "P";
            P--;
        }
        if(L>0)
        {
            cout << "L";
            L--;
        }
        if(T>0)
        {
            cout << "T";
            T--;
        }

    }
    return 0;
}

 

posted @ 2017-07-28 17:46  diamondDemand  阅读(177)  评论(0编辑  收藏  举报