hdu 4764 巴什博弈

Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1136    Accepted Submission(s): 792

Problem Description
Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.
 
Input
There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.
 
Output
For each case, print the winner's name in a single line.
 
Sample Input
1 1 30 3 10 2 0 0
 
Sample Output
Jiang Tang Jiang
 
Source
 
Recommend
liuyiding   |   We have carefully selected several similar problems for you:  5503 5502 5501 5500 5499
 
Statistic | Submit | Discuss | Note
亚洲赛网络赛水题
#include<stdio.h>
int n,k;
int main(){
   while(scanf("%d%d",&n,&k)!=EOF){
        if(n==0&&k==0)
            break;
       int temp=(n-1)%(k+1);
       if(temp>0)
        printf("Tang\n");
       else
        printf("Jiang\n");
   }
   return 0;
}

 

 
posted @ 2015-10-10 23:28  柳下_MBX  阅读(154)  评论(0编辑  收藏  举报