HDU 4180 扩展欧几里得

RealPhobia

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 376    Accepted Submission(s): 151


Problem Description
Bert is a programmer with a real fear of floating point arithmetic. Bert has quite successfully used rational numbers to write his programs but he does not like it when the denominator grows large. Your task is to help Bert by writing a program that decreases the denominator of a rational number, whilst introducing the smallest error possible. For a rational number A/B, where B > 2 and 0 < A < B, your program needs to identify a rational number C/D such that:
1. 0 < C < D < B, and
2. the error |A/B - C/D| is the minimum over all possible values of C and D, and
3. D is the smallest such positive integer.
 

 

Input
The input starts with an integer K (1 <= K <= 1000) that represents the number of cases on a line by itself. Each of the following K lines describes one of the cases and consists of a fraction formatted as two integers, A and B, separated by “/” such that:
1. B is a 32 bit integer strictly greater than 2, and
2. 0 < A < B
 

 

Output
For each case, the output consists of a fraction on a line by itself. The fraction should be formatted as two integers separated by “/”.
 

 

Sample Input
3 1/4 2/3 13/21
 

 

Sample Output
1/3 1/2 8/13
 

 

Source
 

 

Recommend
lcy   |   We have carefully selected several similar problems for you:  4186 4181 4182 4183 4179
 
 
 
#include<stdio.h>
#include<string.h>

long long gcd1(long long a,long long b,long long &x,long long &y)
{
    if(b == 0)
    {
        x = 1;
        y = 0;
        return a;
    }
    long long d = gcd1(b,a%b,x,y);
    long long t = x;
    x = y;
    y = t - a/b*y;
    return d;
}


int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        long long a,b;
        scanf("%lld/%lld",&a,&b);
        long long x = 0,y = 0;
        long long p = gcd1(a,b,x,y);
        //printf("%lld,%lld\n",x,y);
        //printf("---%lld\n",p);
        //printf("==%lld %lld\n",a,b);
        if(p != 1)
        {
            printf("%lld/%lld\n",a/p,b/p);
            continue;
        }
        if(a == 1)
        {
            printf("1/%lld\n",b-1);
            continue;
        }
        long long x1 = 0,y1 = 0;
        if(x > 0)
        {
            x1 = (a + y)%a;
            y1 = (b - x)%b;
        }
        else
        {
            x1 = (a - y)%a;
            y1 = (b + x)%b;
        }
        //printf("%lld %lld %lld %lld\n",x1,y1);
        printf("%lld/%lld\n",x1,y1);
    }
    return 0;
}

 

posted @ 2015-08-14 09:43  柳下_MBX  阅读(206)  评论(0编辑  收藏  举报