poj 2151 概率DP(水)

Check the difficulty of problems
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 5750   Accepted: 2510

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

题意:在acm比赛中,n题,t队。给出每个队做对每题的概率,问每队至少对一题,至少有一队做对至少m题的概率。(本解题报告中的n,m与原题中相反)

分析:dp,f[i][j]表示第i个队伍做对第j题的概率。g[i][j][k]表示第i个队伍对于前j题而言做对k道的概率。

g[i][j][k] = g[i][j - 1][k - 1] * (f[i][j]) + g[i][j - 1][k] * (1 - f[i][j]);

有了所有的g,我们就可以求出每个队至少做对1题的概率:ans *= 1 - g[i][n][0];

再减去每个队都只做对1~m-1题的概率(把每个队做对1~m-1题的概率加和,并把各队结果相乘)

 

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
double f[1005][35];
double dp[1005][35][35];
int main(){
      int n,t,m;
      while(scanf("%d%d%d",&n,&t,&m)!=EOF){
            if(n==0&&t==0&&m==0)
            break;
         memset(f,0,sizeof(f));
         memset(dp,0,sizeof(dp));
         for(int i=0;i<t;i++){
            for(int j=1;j<=n;j++)
                scanf("%lf",&f[i][j]);
         }

         for(int i=0;i<t;i++){
            dp[i][0][0]=1;
            for(int j=1;j<=n;j++){
                dp[i][j][0]=dp[i][j-1][0]*(1-f[i][j]);
                for(int k=1;k<=j;k++)
                    dp[i][j][k]=dp[i][j-1][k-1]*f[i][j]+dp[i][j-1][k]*(1-f[i][j]);
            }
         }

         double ans=1;
         for(int i=0;i<t;i++)
            ans*=(1-dp[i][n][0]);

         double temp=1;
         for(int i=0;i<t;i++){
            double sum=0;
            for(int j=1;j<m;j++)
                sum+=dp[i][n][j];
            temp*=sum;
         }

         printf("%.3lf\n",ans-temp);

      }
      return 0;
}

 

 





posted @ 2015-08-03 19:48  柳下_MBX  阅读(163)  评论(0编辑  收藏  举报