poj1611(感染病患者)
Time Limit: 1000MS | Memory Limit: 20000K | |
Total Submissions: 24587 | Accepted: 12046 |
Description
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
Sample Input
100 4 2 1 2 5 10 13 11 12 14 2 0 1 2 99 2 200 2 1 5 5 1 2 3 4 5 1 0 0 0
Sample Output
4 1 1
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int m,n;
int a[30005];
int b[30005];
int pd[30005];
void update()
{
for(int i=0; i<n; i++)
a[i]=i;
}
int get(int x)
{
if(a[x]!=x)
a[x]=get(a[x]);
return a[x];
}
void unin(int x,int y)
{
a[get(y)]=get(x);
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
if(n==0&&m==0)
break;
memset(b,0,sizeof(b));
memset(pd,0,sizeof(pd));
memset(a,0,sizeof(a));
update();
for(int i=1; i<=m; i++)
{
int ans;
scanf("%d",&ans);
for(int j=1; j<=ans; j++)
{
scanf("%d",&b[j]);
if(pd[b[j]]==0)
pd[b[j]]=1;
if(j!=1)
unin(b[j-1],b[j]);
}
}
int sum=0;
if(m==0)
printf("1\n");
else
{
for(int i=1; i<=30005; i++)
{
if(pd[i]==1&&get(i)==get(0))
sum++;
}
printf("%d\n",sum+1);
}
}
return 0;
}