#include <iostream>#include <iomanip>usingnamespace std;
int main(){
int start,end;
cin >>start>>end;
start = start/100*60+start%100;//将输入的四位数转化为以分钟为单位的时间总和
end = end/100*60+end%100;//将输入的四位数转化为以分钟为单位的时间总和
int hour = (end-start)/60;
int minute = (end-start)%60;
cout<<setfill('0')<<setw(2)<<hour<<";"<<setw(2)<<minute<<endl;
return0;
}
题目三:
【描述】
编写程序,将输入的任意3个整数从小到大输出,其间以"->"相连。
【输入】
一行中输入三个整数,其间以空格间隔。
【输出】
一行中将三个整数从小到大输出,其间以"->"相连。
【输入示例】
4 2 8
【输出示例】
2->4->8
#include<iomanip>#include<iostream>usingnamespace std;
intmain(){
int a,b,c;
cin >>a>>b>>c;
if(a>b){
int t = a;
a = b;
b = t;
}
if(a>c){
int t = a;
a = c;
c = t;
}
if(b>c){
int t = b;
b = c;
c = t;
}
cout<<a<<"->"<<b<<"->"<<c<<endl;
return0;
}
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· 单线程的Redis速度为什么快?
· SQL Server 2025 AI相关能力初探
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
· 展开说说关于C#中ORM框架的用法!