C++记录一

题目一:

【描述】

比较两个整数之间的大于、小于、等于、不等于关系。

【输入】

输入在一行中给出2个整数a和b。

【输出】

分行输出整数a和b之间的大于、小于、等于、不等于关系。

【输入示例】

5 3

【输出示例】

true

false

false

true

#include <iostream>
#include <iomanip>
using namespace std;
int main(){
	int a,b;
	cin >>a>>b;
	cout<<boolalpha<<(a>b)<<endl;
	cout<<boolalpha<<(a<b)<<endl;
	cout<<boolalpha<<(a == b)<<endl;
	cout<<boolalpha<<(a != b)<<endl;
	return 0;
}

题目二:

【描述】

编写程序,根据火车的出发时间和达到时间计算整个旅途所用的时间。

【输入】

在一行中给出两个正整数,其间以空格分隔,分别表示火车的出发时间和到达时间。每个时间的格式为两位小时数(00~23)和两位分钟数(00~59),假设出发和到达在同一天内。

【输出】

在一行中输出该旅途所用的时间,格式为“hh:mm”,其中hh为两位小时数、mm为两位分钟数。

【输入示例】

1201 1530

【输出示例】

03:29

#include <iostream>
#include <iomanip>
using namespace std;
int main(){
	int start,end;
	cin >>start>>end;
	start = start/100*60+start%100;//将输入的四位数转化为以分钟为单位的时间总和 
	end = end/100*60+end%100;//将输入的四位数转化为以分钟为单位的时间总和
	int hour = (end-start)/60;
	int minute = (end-start)%60;
	cout<<setfill('0')<<setw(2)<<hour<<";"<<setw(2)<<minute<<endl;
	return 0;
}

题目三:

【描述】

编写程序,将输入的任意3个整数从小到大输出,其间以"->"相连。

【输入】

一行中输入三个整数,其间以空格间隔。

【输出】

一行中将三个整数从小到大输出,其间以"->"相连。

【输入示例】

4 2 8

【输出示例】

2->4->8

#include <iomanip> 
#include <iostream>
using namespace std;
int main(){
	int a,b,c;
	cin >>a>>b>>c;
	if(a>b){
		int t = a;
		a = b;
		b = t;
	}
	if(a>c){
		int t = a;
		a  = c;
		c = t; 
	}
	if(b>c){
		int t = b;
		b = c;
		c = t;
	}
	cout<<a<<"->"<<b<<"->"<<c<<endl;
	return  0;
}
posted @ 2022-05-08 20:48  CPYQY_orz  阅读(44)  评论(0编辑  收藏  举报