poj 1195 Mobile phones (二维树状数组)

Mobile phones
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 16560   Accepted: 7606

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

Source

 
树状数组二维裸体
需要注意的还是下标,从0开始,会tle ,都+1就好。
/*************************************************************************
    > File Name: code/poj/1195.cpp
    > Author: 111qqz
    > Email: rkz2013@126.com 
    > Created Time: 2015年08月06日 星期四 15时54分03秒
 ************************************************************************/

#include<iostream>
#include<iomanip>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<map>
#include<set>
#include<queue>
#include<vector>
#include<stack>
#define y0 abc111qqz
#define y1 hust111qqz
#define yn hez111qqz
#define j1 cute111qqz
#define tm crazy111qqz
#define lr dying111qqz
using namespace std;
#define REP(i, n) for (int i=0;i<int(n);++i)  
typedef long long LL;
typedef unsigned long long ULL;
const int inf = 0x7fffffff;
const int N=1E3+99;
int a[N][N];
int c[N][N];
int x,y,A,l,b,r,t;
int s;
int lowbit( int x)
{
    return x&(-x);
}
void update( int x,int y,int delta)
{
    for ( int i = x ; i <=s ; i = i + lowbit(i))
    {
    for ( int j = y ; j <= s;  j = j + lowbit(j))
    {
        c[i][j] = c[i][j] + delta;
    }
    }
}
int Sum( int x,int y)
{
    int res = 0 ;
    for ( int i = x; i >= 1;  i = i - lowbit(i))
    {
    for ( int j = y ; j >= 1 ; j = j - lowbit(j))
    {
        res  = res + c[i][j];
    }
    }
    return res;
}
int main()
{
  int cmd ;
  while (scanf("%d",&cmd)!=EOF)
  {
      if (cmd==3) break;
      if (cmd==0)
      {
      scanf("%d",&s);
      memset(a,0,sizeof(a));
      }
      if (cmd==1)
      {
      scanf("%d %d %d",&x,&y,&A);
      a[x][y] +=A;
      update(x+1,y+1,A);
      }
      if (cmd==2)
      {
      scanf("%d %d %d %d",&l,&b,&r,&t);
      cout<<Sum(r+1,t+1)-Sum(l,t+1)-Sum(r+1,b)+Sum(l,b)<<endl;
      }
  }   
    return 0;
}

 

posted @ 2015-08-06 16:20  111qqz  阅读(223)  评论(0编辑  收藏  举报