hdu 4349

Xiao Ming's Hope

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1627    Accepted Submission(s): 1091


Problem Description
Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C(n,0)+C(n,1)+C(n,2)+...+C(n,n)=?". Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C(1,0)=C(1,1)=1, there are 2 odd numbers. When n is equal to 2, C(2,0)=C(2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?
 

 

Input
Each line contains a integer n(1<=n<=108)
 

 

Output
A single line with the number of odd numbers of C(n,0),C(n,1),C(n,2)...C(n,n).
 

 

Sample Input
1 2 11
 

 

Sample Output
2 2 8
 

 

Author
HIT
 

 

Source
 

 

Recommend
zhuyuanchen520
 
 
lucas定理,并没有听过,但是感觉好厉害的样子....
/*************************************************************************
    > File Name: code/whust/#8/E.cpp
    > Author: 111qqz
    > Email: rkz2013@126.com 
    > Created Time: 2015年08月03日 星期一 15时26分58秒
 ************************************************************************/

#include<iostream>
#include<iomanip>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<map>
#include<set>
#include<queue>
#include<vector>
#include<stack>
#define y0 abc111qqz
#define y1 hust111qqz
#define yn hez111qqz
#define j1 cute111qqz
#define tm crazy111qqz
#define lr dying111qqz
using namespace std;
#define REP(i, n) for (int i=0;i<int(n);++i)  
typedef long long LL;
typedef unsigned long long ULL;
const int inf = 0x7fffffff;
int main()
{
    int n;
    while (~scanf("%d",&n))         //Lucas定理,orzorz
    {
    int g = 1 ;
    int s = 0 ;
    while (n)
    {
        s = s + (n&1);
        n = n / 2;
    }
    for ( int i = 1 ; i <= s; i ++)
    {
        g = g * 2;
    }
    printf("%d\n",g);
    }
    return 0;
}

 

posted @ 2015-08-03 15:35  111qqz  阅读(164)  评论(0编辑  收藏  举报