uva12034 递推,dp

 

Disky and Sooma, two of the biggest mega minds of Bangladesh went to a far country. They ate, coded and wandered around, even in their holidays. They passed several months in this way. But everything has an end. A holy person, Munsiji came into their life. Munsiji took them to derby (horse racing). Munsiji enjoyed the race, but as usual Disky and Sooma did their as usual task instead of passing some romantic moments. They were thinking- in how many ways a race can finish! Who knows, maybe this is their romance! In a race there are n horses. You have to output the number of ways the race can finish. Note that, more than one horse may get the same position. For example, 2 horses can finish in 3 ways.

1. Both first

2. horse1 first and horse2 second

3. horse2 first and horse1 second Input Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1000). Output For each case, print the case number and the number of ways the race can finish. The result can be very large, print the result modulo 10056. Sample Input

3

1

2

3

Sample Output

Case 1: 1

Case 2: 3

Case 3: 13

 题意:n匹马赛跑,排名有多少种(可重名)?

假设有i匹马,j个排名,则f[i][j]=j*(f[i-1][j]+f[i-1][j-1])。(第i匹马可能单独排在1~j某一名,即f[i-1][j-1];有可能和其他i-1中的某些一起,即f[i-1][j])

#include <iostream>
#include <cstdio>
#include <cstring>

typedef long long LL;
using namespace std;
const int maxn=1111;
const int mod=10056;

LL f[maxn][maxn];
LL ans[maxn];
int n;
void init()
{
    for(int i=1;i<maxn;i++)
    {
        f[i][1]=1;
        LL sum=1;
        for(int j=2;j<=i;j++)
        {
            f[i][j]=j*((f[i-1][j]+f[i-1][j-1])%mod);
            sum+=f[i][j];
            sum%=mod;
        }
        ans[i]=sum;
        //if(i<10)
        //printf("%lld\n",ans[i]);
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    int t=0;
    init();
    while(T--)
    {
        scanf("%d",&n);
        printf("Case %d: %lld\n",++t,ans[n]);

    }
    return 0;
}

 

posted on 2018-07-26 17:02  一零七  阅读(86)  评论(0编辑  收藏  举报

导航