PAT1094:The Largest Generation

1094. The Largest Generation (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4

思路
图的广搜(BFS),或者可以看成树的层次遍历。仔细看 输入数据 会发现结构很像图的邻接表,所以用vector<vector<int>>模拟一个图的邻接表。所以:
1.根据数据构造图graph。
2.用队列bfs,记录下孩子最多的一层和最多孩子数。(层次的区分可以依靠插入一个label到队列区分,每当一个label出队时,表示这一层遍历完,并且这一层所有节点的孩子都刚好加入队列等待遍历,所以label出队的同时再插入一个label可以将孩子所在的层级与孩子的孩子所在的层级区分开来)
3.输出记录即可。
代码
#include<iostream>
#include<vector>
#include<queue>

//Need to be optimized
using namespace std;
int maxchild = 1,level = 1;

void bfs(int root,const vector<vector<int>>& g)
{
   int curlevel = 0;
   maxchild = 1;
   int countchild = 0;
   int label = -1;
   queue<int> q;
   q.push(root);
   q.push(label);
   while(!q.empty())
   {
       int f = q.front();
       q.pop();
       if( f == label)
       {
           ++curlevel;
           if(maxchild < countchild)
           {
              level = curlevel;
              maxchild = countchild;
           }
           countchild = 0;
           if(q.empty())   //检查下label是不是最后一层的label
            break;
           q.push(label);
       }
       else
       {
           countchild++;
           for(int i = 0;i < g[f].size();i++)
           {
               q.push(g[f][i]);
           }
       }
   }
}

int main()
{
   int N,M;
   while(cin >> N >> M)
   {
       //create graph
       vector<vector<int>> graph(N + 1);
       for(int i = 1; i <=M;i++)
       {
           int node,childcount;
           cin >> node >> childcount;
           vector<int> childs(childcount);
           for(int j = 0;j < childcount;j++)
            cin >> childs[j];
           graph[node] = childs;
       }

       bfs(1,graph);
       cout << maxchild << " " << level;
   }
}

 

 
posted @ 2017-10-03 01:04  0kk470  阅读(439)  评论(0编辑  收藏  举报