SPOJ 694. Distinct Substrings (不相同的子串的个数)

DISUBSTR - Distinct Substrings

no tags 

 

Given a string, we need to find the total number of its distinct substrings.

Input

T- number of test cases. T<=20;
Each test case consists of one string, whose length is <= 1000

Output

For each test case output one number saying the number of distinct substrings.

Example

Sample Input:
2
CCCCC
ABABA

Sample Output:
5
9

Explanation for the testcase with string ABABA:
len=1 : A,B
len=2 : AB,BA
len=3 : ABA,BAB
len=4 : ABAB,BABA
len=5 : ABABA
Thus, total number of distinct substrings is 9.

 

 

这题很简单,不相同子串的个数=所有字串的个数-相同子串的个数

相同子串的个数=sum{ height[2~n] }

 

 

 

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define rep(i,s,t) for(int i=(s);i<(t);i++)
#define per(i,t,s) for(int i=(t);i>=(s);i--)

const int INF = 1e9 + 9;
const int N = 20000 + 9;

/********************倍增算法*后缀数组模板*******************************/


int sa[N], t1[N], t2[N], c[N], rk[N], height[N];
void build_sa (int s[], int n, int m) {
    int i, k, p, *x = t1, *y = t2;
    for (i = 0; i < m; i++) c[i] = 0;
    for (i = 0; i < n; i++) c[x[i] = s[i]]++;
    for (i = 1; i < m; i++) c[i] += c[i - 1];
    for (i = n - 1; i >= 0; i--) sa[--c[x[i]]] = i;
    for (k = 1; k <= n; k <<= 1) {
        p = 0;
        for (i = n - k; i < n; i++) y[p++] = i;
        for (i = 0; i < n; i++) if (sa[i] >= k) y[p++] = sa[i] - k;

        for (i = 0; i < m; i++) c[i] = 0;
        for (i = 0; i < n; i++) c[x[y[i]]]++;
        for (i = 1; i < m; i++) c[i] += c[i - 1];
        for (i = n - 1; i >= 0; i--) sa[--c[x[y[i]]]] = y[i];
        swap (x, y);
        p = 1;
        x[sa[0]] = 0;
        for (i = 1; i < n; i++)
            x[sa[i]] = y[sa[i - 1]] == y[sa[i]] && y[sa[i - 1] + k] == y[sa[i] + k] ? p - 1 : p ++;
        if (p >= n) break;
        m = p;
    }
}
void getHeight (int s[], int n) {
    int i, j, k = 0;
    for (i = 0; i <= n; i++) rk[sa[i]] = i;
    for (i = 0; i < n; i++) {
        if (k) k--;
        j = sa[rk[i] - 1];
        while (s[i + k] == s[j + k]) k++;
        height[rk[i]] = k;
    }
}
/********************************************************************************/

int s[N];
char str[N];
int main() {
    //freopen ("f.txt", "r", stdin);
    int T;
    scanf ("%d", &T);
    while (T--) {
        scanf ("%s", str);
        int n = strlen (str);
        rep (i, 0, n) s[i] = str[i];
        s[n] = 0;
        build_sa (s, n + 1, 128);
        getHeight (s, n);
        int ans = n * (n + 1) / 2;
        rep (i, 2, n + 1) ans -= height[i];
        printf ("%d\n", ans);
    }
    return 0;
}

 

posted @ 2016-08-29 19:04  HARD_UNDERSTAND  阅读(203)  评论(0编辑  收藏  举报