POJ3984 迷宫问题 输出路径【BFS】

题目链接

 

题目大意:

定义一个二维数组: 

int maze[5][5] = {

0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output

左上角到右下角的最短路径,格式如样例所示。


Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

 

#include <cstdio>
#include <cstring>
#define rep(i,s,t) for(int i=s;i<t;i++)
int g[5][5], vis[5][5];
const int dir[][2] = {1,0,0,1,-1,0,0,-1};
struct Node {
    int x, y, pre;
};
Node q[100];

void Print(Node s) {
    if(s.pre != -1) Print(q[s.pre]);
    printf("(%d, %d)\n", s.x, s.y);
}

void bfs() {
    memset(vis, 0, sizeof(vis));
    int head = 0, end = 0;
    Node s;
    s.x = 0, s.y = 0, s.pre = -1;
    vis[0][0]=1;
    q[end++] = s;
    while(head < end) {
        Node now = q[head++];
        if(now.x == 4 && now.y == 4) { Print(now); return; }
        rep(i,0,4) {
            int nx = now.x + dir[i][0];
            int ny = now.y + dir[i][1];
            if(nx < 0 || nx >= 5 || ny < 0 || ny >= 5 || g[nx][ny] == 1 || vis[nx][ny]) continue;
            vis[nx][ny] = 1;
            Node next;
            next.x = nx, next.y = ny, next.pre = head - 1;
            q[end++] = next; 
        }
    }
}

int main() {
    rep(i,0,5) rep(j,0,5) scanf("%d", &g[i][j]);
    bfs();
    return 0;
}

 

 

2018-03-31

 

posted @ 2018-03-31 09:49  悠悠呦~  阅读(71)  评论(0编辑  收藏  举报
浏览器标题切换
浏览器标题切换end