Oil Deposits(DFS) HDU - 1241

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or @', representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@***@
5 5
****@
@@@
@**@
@@@
@
@@**@
0 0
Sample Output
0
1
2
2

我的题解:这道题是lrj紫书上的讲DFS例题,hhhhh.很经典.

#include <bits/stdc++.h>
const int N=105;
using namespace std;
char s[N][N];
int mp[N][N];
int n,m;
int dir[8][2]={-1,0,1,0,0,-1,0,1,-1,-1,1,-1,-1,1,1,1};
void op(){
    for(int i=1;i<=n;i++){for(int j=1;j<=m;j++) printf("%d",mp[i][j]); puts("");}puts("-------------");
}
bool check(int x,int y){
    if(x<=n&&y<=m&&x>=1&&y>=1&&mp[x][y]==0&&s[x][y]=='@') return true;
    return false;
}
void dfs(int x,int y){
    mp[x][y]=1;
    int nx,ny;
    for(int i=0;i<8;i++){
        nx=x+dir[i][0];
        ny=y+dir[i][1];
        if(check(nx,ny)) dfs(nx,ny);
    }
}
int main()
{
    while(cin>>n>>m&&n!=0){
        memset(mp,0,sizeof(mp));
        for(int i=1;i<=n;i++) scanf("%s",s[i]+1);
        int ans=0;
        for(int i=1;i<=n;i++) for(int j=1;j<=m;j++) if(s[i][j]=='@'&&mp[i][j]==0)  dfs(i,j),ans++;
        cout<<ans<<endl;
    }
    //cout << "Hello world!" << endl;
    return 0;
}
posted @ 2019-04-03 01:07  _yjun  阅读(160)  评论(0编辑  收藏  举报