poj Charm BraceletBessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. E

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23



#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;

int dp[100100];

struct node
{
int w;
int v;
}s[100100];

int main()
{
//memset(dp,0,sizeof(dp));
int n,m;
while(scanf("%d %d",&n,&m)!=EOF)//while(scanf("%d %d",&n,&m),n||m)改成这样就会超时
{
for(int i=0;i<=m;i++)
dp[i]=0;
int ans=0;
int x,y;
for(int i=1;i<=n;i++)
{
scanf("%d %d",&s[i].w,&s[i].v);
}
for(int i=1;i<=n;i++)
for(int j=m;j>=s[i].w;j--)
{
dp[j]=max(dp[j],dp[j-s[i].w]+s[i].v);
}
printf("%d\n",dp[m]);
}
return 0;
}




posted on 2016-10-27 22:10  Dove1  阅读(664)  评论(0编辑  收藏  举报