poj2230 欧拉回路

http://poj.org/problem?id=2230

Description

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done. 

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice. 

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M. 

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

Hint

OUTPUT DETAILS: 

Bessie starts at 1 (barn), goes to 2, then 3, etc...

 

题解:

一个图是欧拉图,那么他的子图也是一个欧拉图,只需dfs即可

#include <cstdio>
#include <cstring>
using namespace std;
const int MAXN=1e5+10;
struct node{
    int v;
    int next;
}G[MAXN];
int head[MAXN],cnt;
bool vis[MAXN];
int ans[MAXN];
void add(int u,int v)
{
    G[++cnt].v=v;
    G[cnt].next=head[u];
    head[u]=cnt;
}
int n,m,k=0;
int dfs(int u)
{
    for (int i = head[u]; i!=-1 ; i=G[i].next) {
        if(!vis[i])
        {
            vis[i]= true;
            dfs(G[i].v);
            ans[k++]=G[i].v;
        }
    }
}
int main() {
    while (scanf("%d%d",&n,&m)!=EOF)
    {
        cnt=0,k=0;
        memset(head,-1, sizeof(head));
        memset(vis,false, sizeof(vis));
        int u,v;
        for (int i = 0; i <m ; ++i) {
            scanf("%d%d",&u,&v);
            add(u,v);
            add(v,u);
        }
        dfs(1);
        for (int i = 0; i <k ; ++i) {
            printf("%d\n",ans[i]);
        }
        printf("1\n");
    }
    return 0;
}
//poj2230

  

posted @ 2018-09-13 22:20  岩扉  阅读(336)  评论(0编辑  收藏  举报