hdu 2795 Billboard【线段树,区间求最大值,点更新在区间操作中进行】

题目连接: http://acm.hdu.edu.cn/showproblem.php?pid=2795

 

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5359    Accepted Submission(s): 2469


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

 

Sample Input
3 5 5 2 4 3 3 3
 

 

Sample Output
1 2 1 3 -1
 
大致题意:
给出一个板子,高h, 宽w。在给出一个数n,表示有n组询问。
接下来n行每行一个数x,代表一个小的板子,高为1,宽为x。
小的板子要放在大的板子内,并且尽量往上放。上面有地方放不能放在下面。
问这个板子要放在大板子的哪一行。放不下输出-1.
 
#include<stdio.h>
#include<algorithm>
using namespace std;

#define MAXN 200001

int tree[MAXN << 2];
int h, w, n;

void PushUP(int rt)
{
	//当前节点为左右子节点最大的。
	tree[rt] = max(tree[rt << 1], tree[rt << 1 | 1]);
}

//构建一个线段树,初始化为板子的宽度。
void build(int l, int r, int rt)
{
	tree[rt] = w;
	if( l == r ) return ;
	
	int mid = (l + r) >> 1;
	build(l, mid, rt << 1);
	build(mid + 1, r, rt << 1 | 1);
}

//查询,更新操作在查询中进行了。
int query(int p, int l, int r, int rt)
{
	if( l == r ) {
		tree[rt] -= p;
		return l;
	}

	int mid = (l + r) >> 1;
	int ans;
	ans = p <= tree[rt << 1] ? query(p, l, mid, rt << 1) : query(p, mid + 1, r, rt << 1 | 1);
	PushUP( rt );
	return ans;
}

int main()
{
	while(scanf("%d %d %d", &h, &w, &n) != EOF) {
		if(h > n) h = n;
		build(1, h, 1);
		while( n-- ) {
			int a;
			scanf("%d", &a);
			if(a > tree[1]) {
				printf("-1\n");
			} else {
				printf("%d\n", query(a, 1, h, 1));
			}
		}
	}
	return 0;
}

  

posted @ 2012-10-30 19:50  小猴子、  阅读(317)  评论(0编辑  收藏  举报