hdu1028 Ignatius and the Princess III(递归、DP)

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25805    Accepted Submission(s): 17839


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

 

Sample Input
4
10
20
 

 

Sample Output
5
42
627
 
 
递归
#include<stdio.h>
#include<string.h>
const int MAXN=130;
int dp[MAXN][MAXN];//用数组记录计算结果,节约时间
//dp[i][j]表示将i分成j部分的和等于i的方法数
int calc(int n,int m)
{
    if(dp[n][m]!=-1) 
        return dp[n][m];
    if(n<1||m<1)
        return dp[n][m]=0;
    if(n==1||m==1) 
        return dp[n][m]=1;
    if(n<m) 
        return dp[n][m]=calc(n,n);
    if(n==m) 
        return dp[n][m]=calc(n,m-1)+1;
    return dp[n][m]=calc(n,m-1)+calc(n-m,m);
    
}     
int main()
{
    int n;
    memset(dp,-1,sizeof(dp));
    while(scanf("%d",&n)!=EOF)
      printf("%d\n",calc(n,n));
    return 0;
}

 

 

DP

#include<iostream>
using namespace std;
int main()
{
    int n;
    while (cin >> n)
    {
        int dp[121] = { 0 };
        dp[0] = 1;
        for (int i = 1; i <= n; i++)//分成几部分
        {
            for (int j = i; j <= n; j++)//每一部分先放1个有dp[j]种放法,剩下的j-i个随便放有dp[j-i]种放法
            {
                dp[j] = dp[j] + dp[j - i];//不断更新
            }
        }
        cout << dp[n] << endl;
    }
}

 

posted @ 2018-08-21 15:05  知道了呀~  阅读(182)  评论(0编辑  收藏  举报