hdu 1671 Phone List 统计前缀次数

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 27948    Accepted Submission(s): 9204


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

 

Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
 
 
Sample Output
NO
YES
 
题意:判断电话号码是不是其它电话号码的前缀,是输出YES,否则输出NO
 
注意开数组的大小100050
#include<iostream>
#include<string>
#include<string.h>
using namespace std;
int vis[100050],tree[100050][26];
int root,id,len,n,t,i,num,flag;
string s[100050];

void insert()
{
    root=0;
    len=s[i].length();
    for(int j=0;j<len;j++)
    {
        id=s[i][j]-'a';
        if(!tree[root][id])
            tree[root][id]=++num;
        vis[tree[root][id]]++;
        root=tree[root][id];
    }
}

int search(string ss)
{
    root=0;
    len=ss.length();
    for(int j=0;j<len;j++)
    {
        id=ss[j]-'a';
        if(!tree[root][id])
            return 0;
        root=tree[root][id];
    }
    return vis[root];
}
int main()
{
    cin>>t;
    while(t--)
    {
        flag=0,num=0,i=0;
        memset(tree,0,sizeof(tree));
        memset(vis,0,sizeof(vis));
        cin>>n;
        for(i=0;i<n;i++)
        {
            cin>>s[i];
            insert();
        }
        for(int j=0;j<n;j++)
        {
            if(search(s[j])!=1)
            {
                flag=1;
                cout<<"NO"<<endl;
                break;
            }
        }
        if(flag==0)
            cout<<"YES"<<endl;

    }
    return 0;
}

 

posted @ 2019-07-12 10:26  知道了呀~  阅读(521)  评论(0编辑  收藏  举报