Fork me on GitHub

HDU 1541 树状数组

http://acm.hdu.edu.cn/showproblem.php?pid=1541

Stars
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1849 Accepted Submission(s): 714

Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input
5
1 1
5 1
7 1
3 3
5 5

Sample Output
1
2
1
1
0

 

利用点的x坐标构造树,如果题目给出的点没有排好序,则要自己排序

/*
*题目大意——求一颗星星的左下方有多少颗星星
*/

#include <iostream>
using namespace std;

const int MAX_STAR_NUMBER=15005;
const int MAX_COORDINATE_NUMBER=32005;

int level[MAX_STAR_NUMBER];
int bit[MAX_COORDINATE_NUMBER];

int LowBit(int x)
{
    return x&(x^(x-1));
}

void Add(int i,int value,int n)
{
    while(i<=MAX_COORDINATE_NUMBER)
    {
        bit[i]+=value;
        i+=LowBit(i);
    }
}

int Sum(int i)
{
    int sum=0;
    while(i>0)
    {
        sum+=bit[i];
        i-=LowBit(i);
    }
    return sum;
}


int main()
{
    int n;
    int x,y;
    while(cin>>n)
    {
        memset(bit,0,sizeof(bit));
        memset(level,0,sizeof(level));
        
        for(int i=0;i<n;i++)
        {
            cin>>x>>y;
            level[Sum(++x)]++;
            Add(x,1,n);
        }

        for(int i=0;i<n;i++)
            cout<<level[i]<<endl;
    }
    return 0;
}
posted @ 2012-04-20 21:24  _Lei  阅读(510)  评论(0编辑  收藏  举报