POJ3660

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2
代码
#include<stdio.h>
#include<stdlib.h>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define maxn 110

using namespace std;

int map[maxn][maxn];
int n,m,a,b,i,j,k;


void floyed()
{
    for(k=1;k<=n;k++)
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
            if(map[i][k]&&map[k][j]&&i!=j)
            map[i][j] = 1;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(map,0,sizeof(map));
        for(int i=1;i <=m;i++)
        {
            scanf("%d%d",&a,&b);
            map[a][b] = 1;
        }

        floyed();

        int ans = 0;
        for(int i = 1; i <= n; i++)
        {
            int temp = 0;
                for(int j = 1; j <= n; j++)
                {
                    if(map[i][j] || map[j][i])
                        temp++;
                }
                if(temp == n-1)
                    ans++;
        }
                printf("%d\n",ans);
    }
}
posted @ 2017-04-16 00:29  TTTCoder  阅读(269)  评论(0编辑  收藏  举报