Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 
Input
The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.
Output
For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.
Sample Input
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
Sample Output
28

题意:N个农场,要通过光纤互相连接,求最小成本。N*N代表成本情况,如21代表1->4花费21,17代表2->4花费17.。。。。

题解:直接套用模板即可,用结构体排序,成本小的在前面。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n;
int f[220];
struct note
{
    int u,v,w;
} q[20000];
void init()
{
    for(int i=0; i<=n; i++)
    {
        f[i]=i;
    }
}
int getf(int v)
{
    if(f[v]==v)return v;
    else
    {
        f[v]=getf(f[v]);
        return f[v];
    }
}
int merge(int v,int u)
{
    int t1=getf(v);
    int t2=getf(u);
    if(t1!=t2)
    {
        f[t2]=t1;
        return 1;
    }
    return 0;
}
int cmp(note a,note b)
{
    return a.w<b.w;
}
int main()
{
    while(~scanf("%d",&n))
    {
        init();
        int sum=0;
        int cnt=0;
        int a;
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
            {
                scanf("%d",&a);
                if(i==j)continue;
                q[cnt].u=i,q[cnt].v=j,q[cnt++].w=a;
            }
        sort(q,q+cnt,cmp);
        for(int i=0; i<cnt; i++)
        {
            if(merge(q[i].u,q[i].v))
            {
                sum+=q[i].w;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

posted on 2018-04-26 15:09  zitian246  阅读(98)  评论(0编辑  收藏  举报