Climbing Worm

Climbing Worm

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17029    Accepted Submission(s): 11638


Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
 

 

Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
 

 

Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
 

 

Sample Input
10 2 1 20 3 1 0 0 0
 

 

Sample Output
17 19
 

 

Source
//杭电1049 Climbing Worm
#include <iostream>
#include<stdio.h>
#include<algorithm>
#include<iomanip>
using namespace std;

int main()
{
    int n,u,d;
    int t,i;
    while(scanf("%d %d %d",&n,&u,&d)!=EOF&&n!=0)
    {
        if(n<=u)//高度小于每分钟爬的高度时,只需1分钟//<=很重要,有一个错误,最终发现在这
        {
            t=1;
        }
        else
        {
            for(i=1; ;i++)
            {
                if(n<=(u-d)*i+u)
                    break;
            }
            t=i*2+1;
        }
         printf("%d\n",t);
    }
    return 0;
}
//杭电1049 Climbing Worm
#include <iostream>
#include<stdio.h>
#include<algorithm>
#include<iomanip>
using namespace std;

int main()
{
    int n,u,d;
    int t,s;
    while(scanf("%d %d %d",&n,&u,&d)!=EOF&&n!=0)
    {
        t=0;s=0;
        while(1)
        {
            s+=u;
            t++;
            if(s>=n)
            break;
            s-=d;
            t++;
        }
        printf("%d\n",t);
    }
    return 0;
}

 

 
posted @ 2016-07-23 15:17  多思考&&多动手  阅读(301)  评论(0编辑  收藏  举报