USACO Section 3.4 American Heritage(知先序中序求后序)

American Heritage

Farmer John takes the heritage of his cows very seriously. He is not, however, a truly fine bookkeeper. He keeps his cow genealogies as binary trees and, instead of writing them in graphic form, he records them in the more linear `tree in-order' and `tree pre-order' notations.

Your job is to create the `tree post-order' notation of a cow's heritage after being given the in-order and pre-order notations. Each cow name is encoded as a unique letter. (You may already know that you can frequently reconstruct a tree from any two of the ordered traversals.) Obviously, the trees will have no more than 26 nodes.

Here is a graphical representation of the tree used in the sample input and output:

                  C
                /   \
               /     \
              B       G
             / \     /
            A   D   H
               / \
              E   F

The in-order traversal of this tree prints the left sub-tree, the root, and the right sub-tree.

The pre-order traversal of this tree prints the root, the left sub-tree, and the right sub-tree.

The post-order traversal of this tree print the left sub-tree, the right sub-tree, and the root.

PROGRAM NAME: heritage

INPUT FORMAT

Line 1: The in-order representation of a tree.
Line 2: The pre-order representation of that same tree.

SAMPLE INPUT (file heritage.in)

ABEDFCHG
CBADEFGH

OUTPUT FORMAT

A single line with the post-order representation of the tree.

SAMPLE OUTPUT (file heritage.out)

AEFDBHGC 
题意:告诉你中序和先序求后序;
分析:递归求解

View Code
/*
  ID: dizzy_l1
  LANG: C++
  TASK: heritage
*/
#include<iostream>
#include<cstring>
#include<cstdio>
#include<string>

using namespace std;

string pre_order,in_order;

void output(int pre_L,int pre_R,int in_L,int in_R)
{
    int in_M;
    if(pre_L>pre_R) return ;
    if(pre_L==pre_R)
    {
        cout<<pre_order[pre_L];
        return ;
    }
    in_M=in_order.find(pre_order[pre_L]);
    output(pre_L+1,pre_L+in_M-in_L,in_L,in_M-1);
    output(pre_L+in_M-in_L+1,pre_R,in_M+1,in_R);
    output(pre_L,pre_L,in_M,in_M);
}

void work()
{
    int in_L,in_R,pre_L,pre_R;
    pre_L=in_L=0;pre_R=in_R=pre_order.length()-1;
    output(pre_L,pre_R,in_L,in_R);
}

int main()
{
    freopen("heritage.in","r",stdin);
    freopen("heritage.out","w",stdout);
    cin>>in_order>>pre_order;
    work();
    printf("\n");
    return 0;
}
posted @ 2012-09-19 15:46  mtry  阅读(297)  评论(0编辑  收藏  举报