nyoj5 字符串匹配
Binary String Matching
时间限制:3000 ms | 内存限制:65535 KB
- 描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
- 输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
- 输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
- 样例输入
- 3
11
1001110110
101
110010010010001
1010
110100010101011
样例输出
3
0
3
算法实现:暴力的字符串匹配 你 O (n*m)
View Code
#include<iostream>
#include<string>
using namespace std;
int work(string A,string B)
{
int len1=A.length(),len2=B.length();
int i,j,ans=0;
for(i=0;i<=len2-len1;i++)
{
for(j=0;j<len1;j++)
{
if(A[j]!=B[i+j]) break;
}
if(j==len1) ans++;
}
return ans;
}
int main()
{
int ntest;
cin>>ntest;
string A,B;
while(ntest--)
{
cin>>A>>B;
cout<<work(A,B)<<endl;
}
return 0;
}