poj3177 Redundant Paths

Redundant Paths
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 16108   Accepted: 6753

Description

In order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1..F) to another field, Bessie and the rest of the herd are forced to cross near the Tree of Rotten Apples. The cows are now tired of often being forced to take a particular path and want to build some new paths so that they will always have a choice of at least two separate routes between any pair of fields. They currently have at least one route between each pair of fields and want to have at least two. Of course, they can only travel on Official Paths when they move from one field to another. 

Given a description of the current set of R (F-1 <= R <= 10,000) paths that each connect exactly two different fields, determine the minimum number of new paths (each of which connects exactly two fields) that must be built so that there are at least two separate routes between any pair of fields. Routes are considered separate if they use none of the same paths, even if they visit the same intermediate field along the way. 

There might already be more than one paths between the same pair of fields, and you may also build a new path that connects the same fields as some other path.

Input

Line 1: Two space-separated integers: F and R 

Lines 2..R+1: Each line contains two space-separated integers which are the fields at the endpoints of some path.

Output

Line 1: A single integer that is the number of new paths that must be built.

Sample Input

7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7

Sample Output

2

Hint

Explanation of the sample: 

One visualization of the paths is: 
   1   2   3
+---+---+
| |
| |
6 +---+---+ 4
/ 5
/
/
7 +
Building new paths from 1 to 6 and from 4 to 7 satisfies the conditions. 
   1   2   3
+---+---+
: | |
: | |
6 +---+---+ 4
/ 5 :
/ :
/ :
7 + - - - -
Check some of the routes: 
1 – 2: 1 –> 2 and 1 –> 6 –> 5 –> 2 
1 – 4: 1 –> 2 –> 3 –> 4 and 1 –> 6 –> 5 –> 4 
3 – 7: 3 –> 4 –> 7 and 3 –> 2 –> 5 –> 7 
Every pair of fields is, in fact, connected by two routes. 

It's possible that adding some other path will also solve the problem (like one from 6 to 7). Adding two paths, however, is the minimum.

Source

题目大意:有 F 个牧场,现在一个牧群经常需要从一个牧场迁移到另一个牧场。奶牛们已经厌烦老 是走同一条路,所以有必要再新修几条路,这样它们从一个牧场迁移到另一个牧场时总是可 以选择至少两条独立的路。现在 F 个牧场的任何两个牧场之间已经至少有一条路了,奶牛们 需要至少有两条。 给定现有的 R 条直接连接两个牧场的路,计算至少需要新修多少条直接连接两个牧场的 路,使得任何两个牧场之间至少有两条独立的路。两条独立的路是指没有公共边的路,但可 以经过同一个中间顶点。 1<=F<=5000 ; F-1<=R<=10000
分析:比较明显,先要求出边-双连通分量,然后有一个定理:缩点后的图一定是一棵树,我们只需要知道叶子节点的个数cnt,那么只需要加(cnt + 1) / 2条边就好了,证明比较复杂,暂时就不罗列了.考虑要如何实现这些细节.
      由于缩点后我们要对桥进行操作,如果重新给点编序号,则会很难处理,所以我们考虑记录边上的信息。便利每一条边,如果这条边是桥,那么就把这个桥连着的两个双连通分量的度数各+1,最后度数为1的点就是叶子节点。要怎么缩点呢?注意,这是一个无向图,最好的方法还是并查集啦.
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

const int maxn = 5010,maxm = 20010;
int fa[maxn],du[maxn],head[maxn],bian[maxm],low[maxn],pre[maxn],dfs_clock,from[maxn],nextt[maxm],to[maxm],tot = 1;
bool flag[maxm];
int n,m,ans;

void add(int x,int y)
{
    nextt[++tot] = head[x];
    head[x] = tot;
    to[tot] = y;
    from[tot] = x;
}

void tarjan(int u)
{
    pre[u] = low[u] = ++dfs_clock;
    for (int i = head[u];i;i = nextt[i])
    {
        if (i == (bian[u] ^ 1))
        continue;
        int v = to[i];
        if (!pre[v])
        {
            bian[v] = i;
            tarjan(v);
            if (low[v] < low[u])
            low[u] = low[v];
            if (low[v] > pre[u])
            flag[bian[v]] = flag[bian[v] ^ 1] = 1;
        }
        else
        if (pre[v] < low[u])
        low[u] = pre[v];
    }
}

int find(int x)
{
    if (x == fa[x])
    return x;
    return fa[x] = find(fa[x]);
}

int main()
{
    scanf("%d%d",&n,&m);
    for (int i = 1; i <= n; i++)
    fa[i] = i;
    for (int i = 1; i <= m; i++)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        add(a,b);
        add(b,a);
    }
    for (int i = 1; i <= n; i++)
    if (!pre[i])
    tarjan(i);
    for (int i = 2; i <= tot; i += 2)
    if (!flag[i])
    fa[find(to[i])] = find(from[i]);
    for (int i = 2; i <= tot; i += 2)
    if (flag[i])
    {
    ++du[find(to[i])];
    ++du[find(from[i])];
    }
    for (int i = 1; i <= n; i++)
    if (find(i) == i && du[i] == 1)
    ans++;
    printf("%d\n",(ans + 1) / 2);

    return 0;
}

 

posted @ 2017-09-14 21:18  zbtrs  阅读(179)  评论(0编辑  收藏  举报