uva_11806_Cheerleaders

In most professional sporting events, cheerleaders play a major role in entertaining the spectators. Their roles are substantial during breaks and prior to start of play. The world cup soccer is no exception. Usually the cheerleaders form a group and perform at the centre of the field. In addition to this group, some of them are placed outside the side line so they are closer to the spectators. The organizers would like to ensure that at least one cheerleader is located on each of the four sides. For this problem, we will model the playing ground as an M ×N rectangular grid. The constraints for placing cheerleaders are described below:

• There should be at least one cheerleader on each of the four sides. Note that, placing a cheerleader on a corner cell would cover two sides simultaneously.

• There can be at most one cheerleader in a cell.

• All the cheerleaders available must be assigned to a cell. That is, none of them can be left out.

 

 


The organizers would like to know, how many ways they can place the cheerleaders while maintaining the above constraints. Two placements are different, if there is at least one cell which contains a cheerleader in one of the placement but not in the other.
Input

The first line of input contains a positive integer T ≤ 50, which denotes the number of test cases. T lines then follow each describing one test case. Each case consists of three nonnegative integers, 2 ≤ M, N ≤ 20 and K ≤ 500. Here M is the number of rows and N is the number of columns in the grid. K denotes the number of cheerleaders that must be assigned to the cells in the grid.
Output
For each case of input, there will be one line of output. It will first contain the case number followed by the number of ways to place the cheerleaders as described earlier. Look at the sample output for exact formatting. Note that, the numbers can be arbitrarily large. Therefore you must output the answers modulo 1000007.
Sample Input
2 2 2 1 2 3 2
Sample Output
Case 1: 0 Case 2: 2

 

k个石子,m*n的方格中让你在第一列、最后一列、第一行、最后一行都放置至少一个石子,求方案数;

思路: 容斥+组合数

通过第一行、最后一行、第一列、最后一列都没有的方案数求得

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define ll long long
#define mod 1000007
const int MAXN = 505;  // 组合上限
ll c[MAXN][MAXN];    // 组合数

void GetGroup()
{
    c[0][0] = c[1][0] = c[1][1] = 1;
    for (int i = 2; i < MAXN; i++)
    {
        c[i][0] = 1;
        for (int j=1; j<=i; ++j)
            c[i][j] = (c[i-1][j] + c[i-1][j-1]) % mod;  // 求模,防止结果过大
    }
    return ;
}


int main()
{
	int n,m,t,cas=0,k;
    GetGroup();
    scanf("%d",&t);
	while(t--)
	{
	    scanf("%d%d%d",&m,&n,&k);
	    ll ans=0;
	    for(int i=0;i<16;i++)
        {
            int cnt=0,l=n,r=m;
            if(i&1)
            {
                cnt++;
                l--;
            }
            if(i&2)
            {
                cnt++;
                r--;
            }
            if(i&4)
            {
                cnt++;
                l--;
            }
            if(i&8)
            {
                cnt++;
                r--;
            }
            if(cnt&1)
            {
                ans=(ans-c[l*r][k]+mod)%mod;
            }
            else
                ans=(ans+c[l*r][k])%mod;
        }
	    printf("Case %d: %lld\n",++cas,ans);

	}
	return 0;
}

  

 

posted @ 2018-01-01 17:12  会飞的雅蠛蝶  阅读(111)  评论(0编辑  收藏  举报