hdu 2039

三角形

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 84433    Accepted Submission(s): 28005


Problem Description
给定三条边,请你判断一下能不能组成一个三角形。
 

Input
输入数据第一行包含一个数M,接下有M行,每行一个实例,包含三个正数A,B,C。其中A,B,C <1000;
 

Output
对于每个测试实例,如果三条边长A,B,C能组成三角形的话,输出YES,否则NO。
 

Sample Input
2 1 2 3 2 2 2
 

Sample Output
NO YES
 

Author
linle
#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
    int num,i;
    double x,y,z;//double
    cin>>num;
    while(num--)
    {
    	cin>>x>>y>>z;
    	if(x+y>z&&x+z>y&&z+y>x)
    	cout<<"YES"<<endl;
    	else
    	cout<<"NO"<<endl;
	}
	return 0;
}
     


posted @ 2017-02-03 15:58  X_na  阅读(116)  评论(0编辑  收藏  举报