hdu 1020 Encoding

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43496    Accepted Submission(s): 19218


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
2 ABC ABBCCC
 

Sample Output
ABC A2B3C
题意是说假如输入“AABBAA” 应输入2A2B2A(坑在这)
#include<iostream>
#include<string>
#include<math.h>
#include<string.h>
#include<stdio.h>
#include<algorithm>
#include<map> 
using namespace std;
int main()
{
	int num,j,k,i;
	cin>>num;
	while(num--)
	{
		string s1;
		int sum=0,k=0;
		cin>>s1;
		sum=0;
		for(i=1;i<=s1.size();i++)
		{
		    if(s1[i]!=s1[i-1])
		    {   
		    	sum=i-k+1-1;
		    	if(sum==1)
		    	cout<<s1[i-1];
		    	else
		    	cout<<sum<<s1[i-1];
		    	k=i;	
			}
		}
		cout<<endl;
	  }	
   return 0;
} 


posted @ 2017-02-04 22:05  X_na  阅读(85)  评论(0编辑  收藏  举报