[codeforces 339]C. Xenia and Weights

[codeforces 339]C. Xenia and Weights

试题描述

Xenia has a set of weights and pan scales. Each weight has an integer weight from 1 to 10 kilos. Xenia is going to play with scales and weights a little. For this, she puts weights on the scalepans, one by one. The first weight goes on the left scalepan, the second weight goes on the right scalepan, the third one goes on the left scalepan, the fourth one goes on the right scalepan and so on. Xenia wants to put the total of m weights on the scalepans.

Simply putting weights on the scales is not interesting, so Xenia has set some rules. First, she does not put on the scales two consecutive weights of the same weight. That is, the weight that goes i-th should be different from the (i + 1)-th weight for any i(1 ≤ i < m). Second, every time Xenia puts a weight on some scalepan, she wants this scalepan to outweigh the other one. That is, the sum of the weights on the corresponding scalepan must be strictly greater than the sum on the other pan.

You are given all types of weights available for Xenia. You can assume that the girl has an infinite number of weights of each specified type. Your task is to help Xenia lay m weights on ​​the scales or to say that it can't be done.

输入

The first line contains a string consisting of exactly ten zeroes and ones: the i-th (i ≥ 1) character in the line equals "1" if Xenia has i kilo weights, otherwise the character equals "0". The second line contains integer m (1 ≤ m ≤ 1000).

输出

In the first line print "YES", if there is a way to put m weights on the scales by all rules. Otherwise, print in the first line "NO". If you can putm weights on the scales, then print in the next line m integers — the weights' weights in the order you put them on the scales.

If there are multiple solutions, you can print any of them.

输入示例

0000000101
3

输出示例

YES
8 10 8

数据规模及约定

见“输入

题解

一开始我想贪心,但强大的 cf 数据一巴掌把我打了回来。于是就开始想怎么 dp,发现可以设 f(i, j, k) 表示添加第 i 个砝码,使得砝码 i 所对应的天平中总质量比另一个天平总质量多 j,且当前砝码质量为 k,那么就可以转移了,枚举一下当前添加的砝码的质量,状态数 O(100m),转移 O(10),总时间复杂度相当于 O(m2)。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <stack>
#include <vector>
#include <queue>
#include <cstring>
#include <string>
#include <map>
#include <set>
using namespace std;

const int BufferSize = 1 << 16;
char buffer[BufferSize], *Head, *Tail;
inline char Getchar() {
    if(Head == Tail) {
        int l = fread(buffer, 1, BufferSize, stdin);
        Tail = (Head = buffer) + l;
    }
    return *Head++;
}
int read() {
    int x = 0, f = 1; char c = getchar();
    while(!isdigit(c)){ if(c == '-') f = -1; c = getchar(); }
    while(isdigit(c)){ x = x * 10 + c - '0'; c = getchar(); }
    return x * f;
}

#define maxn 15
#define maxm 1010
char has[maxn];
int m, f[maxm][maxn][maxn], ans[maxm], cnt;
struct Node {
	int i, j, k;
	Node() {}
	Node(int _1, int _2, int _3): i(_1), j(_2), k(_3) {}
} fa[maxm][maxn][maxn];

int main() {
	scanf("%s", has + 1);
	m = read();
	
	for(int j = 1; j <= 10; j++)
		if(has[j] == '1') f[1][j][j] = 1;
	for(int i = 1; i <= m; i++)
		for(int j = 1; j <= 10; j++)
			for(int k = 1; k <= 10; k++)
				fa[i][j][k] = Node(-1, -1, -1);
	for(int i = 2; i <= m; i++)
		for(int j = 1; j <= 9; j++)
			for(int k = 1; k <= 10; k++)
				for(int x = 1; x <= 10; x++)
					if(has[x] == '1' && x != k && x > j && f[i-1][x-j][k])
						f[i][j][x] = 1, fa[i][j][x] = Node(i-1, x-j, k);
	
	bool ok = 0;
	for(int j = 1; j <= 10; j++) {
		for(int k = 1; k <= 10; k++)
			if(f[m][j][k]) {
				ok = 1;
				Node u = Node(m, j, k);
				while(u.i >= 0) {
					ans[++cnt] = u.k;
					u = fa[u.i][u.j][u.k];
				}
				break;
			}
		if(ok) break;
	}
	
	if(!ok) return puts("NO"), 0;
	puts("YES");
	for(int i = cnt; i > 1; i--) printf("%d ", ans[i]); printf("%d\n", ans[1]);
	
	return 0;
}
/*
1111000011
16
1111000011
1
*/

 

posted @ 2016-09-02 15:55  xjr01  阅读(350)  评论(0编辑  收藏  举报