Ignatius and the Princess IV(乱搞一发竟然过了)

B - Ignatius and the Princess IV
Time Limit:1000MS     Memory Limit:32767KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says. 

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says. 

"But what is the characteristic of the special integer?" Ignatius asks. 

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says. 

Can you find the special integer for Ignatius? 
 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file. 
 

Output

For each test case, you have to output only one line which contains the special number you have found. 
 

Sample Input

5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output

3 5 1
 
/*
题意:给你奇数个数,然后让你找出一个数,这个数在里面至少出现过(n+1)/2次

初步思路:感觉可以暴力搞一下
*/
#include <bits/stdc++.h>
using namespace std;
int n;
int a;
int vis[1000005];
void init(){
    memset(vis,0,sizeof vis);
}
int main(){
    // freopen("in.txt","r",stdin);
    while(scanf("%d",&n)!=EOF){
        init();
        int res=0;
        for(int i=0;i<n;i++){
            scanf("%d",&a);
            vis[a]++;
            if(vis[a]>=(n+1)/2)
                res=a;
        }
        printf("%d\n",res);
    }
    return 0;
}

 

posted @ 2017-03-14 13:05  勿忘初心0924  阅读(239)  评论(0编辑  收藏  举报