(匈牙利算法+贪心) hdu 3729

I'm Telling the Truth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1590    Accepted Submission(s): 785


Problem Description
After this year’s college-entrance exam, the teacher did a survey in his class on students’ score. There are n students in the class. The students didn’t want to tell their teacher their exact score; they only told their teacher their rank in the province (in the form of intervals).

After asking all the students, the teacher found that some students didn’t tell the truth. For example, Student1 said he was between 5004th and 5005th, Student2 said he was between 5005th and 5006th, Student3 said he was between 5004th and 5006th, Student4 said he was between 5004th and 5006th, too. This situation is obviously impossible. So at least one told a lie. Because the teacher thinks most of his students are honest, he wants to know how many students told the truth at most.
 

 

Input
There is an integer in the first line, represents the number of cases (at most 100 cases). In the first line of every case, an integer n (n <= 60) represents the number of students. In the next n lines of every case, there are 2 numbers in each line, Xi and Yi (1 <= Xi <= Yi <= 100000), means the i-th student’s rank is between Xi and Yi, inclusive.

 

 

Output
Output 2 lines for every case. Output a single number in the first line, which means the number of students who told the truth at most. In the second line, output the students who tell the truth, separated by a space. Please note that there are no spaces at the head or tail of each line. If there are more than one way, output the list with maximum lexicographic. (In the example above, 1 2 3;1 2 4;1 3 4;2 3 4 are all OK, and 2 3 4 with maximum lexicographic)
 

 

Sample Input
2 4 5004 5005 5005 5006 5004 5006 5004 5006 7 4 5 2 3 1 2 2 2 4 4 2 3 3 4
 

 

Sample Output
3 2 3 4 5 1 3 5 6 7
 

 

Source
 
题意:
 
判断最多有多少人说实话,给出分数的区间,并且输出说真话的人,字典序最大(贪心即可)
 
求解:
 
判断最多有多少人说实话,直接 匈牙利算法就ok
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
vector<int> e[65];
int n,link[100005],mark[100005],vis[65];
bool dfs(int x)
{
    for(int i=0;i<e[x].size();i++)
    {
        int v=e[x][i];
        if(mark[v]==-1)
        {
            mark[v]=1;
            if(link[v]==-1||dfs(link[v]))
            {
                link[v]=x;
                vis[x]=1;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    int tt,a,b;
    scanf("%d",&tt);
    while(tt--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            e[i].clear(),vis[i]=0;
        memset(link,-1,sizeof(link));
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a,&b);
            for(int j=a;j<=b;j++)
            {
                e[i].push_back(j);
            }
        }
        int ans=0;
        for(int i=n;i>=1;i--)
        {
            memset(mark,-1,sizeof(mark));
            if(dfs(i))
                ans++;
        }
        printf("%d\n",ans);
        for(int i=1;i<=n;i++)
        {
            if(vis[i])
            {
                ans--;
                if(ans>=1)
                    printf("%d ",i);
                else
                    printf("%d\n",i);
            }
        }
    }
    return 0;
}

  

posted @ 2015-04-27 14:42  waterfull  阅读(709)  评论(0编辑  收藏  举报