poj 2769 Reduced ID Numbers


Reduced ID Numbers
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 7346   Accepted: 2971

Description

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8
#include<iostream>
#include<algorithm>
using namespace std;

int comp(int &a,int &b)
{
return a<b;
}

int main()
{
int nums[300];
int modu[300];
int g;
int n;
int divi;
int i;
cin>>n;
while(n--)
{
cin>>g;
for(i=0;i<g;i++)
cin>>nums[i];
for(divi=g;;divi++)
{
for(i=0;i<g;i++)
{
modu[i]=nums[i]%divi;
}
sort(modu,modu+g,comp);
for(i=0;i<g-1;i++)
{
if(modu[i]==modu[i+1])
break;
}
if(i==g-1)
{
cout<<divi<<endl;
break;
}
}
}
return 0;
}
posted @ 2011-11-22 13:08  w0w0  阅读(157)  评论(0编辑  收藏  举报